Configure Equal-cost dan Unequal-cost Load Balancing With EIGRP

Posted On 19 August 2009

Filed under EIGRP

Comments Dropped leave a response

EhMM,,, Sore semua…..!!!

Sekarang kita akan mencoba mengkonfigure load balancing dengan EIGRP. Yang pertama, load balancing antar 2 link yang memiliki cost/metric bobot yang sama. Kemudian kita akan mencoba juga jika metric antar 2 link itu berbeda.

Ini diagram network yang akan kita buat…

Konfigurasi masing2 Router sebagai berikut _________________________________________________________________________________________

show running-config _________________________________________________________________________________________

R1#sh run
Building configuration…

Current configuration : 1007 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$d9oZ$xnn0lRXOcw6Lkb6Ivcaad.
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback10
ip address 70.0.0.1 255.255.255.255
!
interface FastEthernet0/0
description R1 –> R3
ip address 10.10.100.1 255.255.255.252

duplex auto
speed auto
!
interface FastEthernet0/1
description R1 –> R2
ip address 10.20.100.2 255.255.255.252

duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.8.8.254 255.255.255.0
duplex auto
speed auto
!
router eigrp 99
network 10.10.100.0 0.0.0.3
network 10.20.100.0 0.0.0.3
network 70.0.0.0
no auto-summary
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
password rahman
login
transport preferred none
!
end

==============================================================================================

R2#sh run
Building configuration…

Current configuration : 995 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$J7G8$MpcFUIBZAiwoue70vTROG0
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback20
ip address 80.0.0.1 255.255.255.255
!
interface FastEthernet0/0
description R2 –> R3
ip address 10.30.100.2 255.255.255.252

duplex auto
speed auto
!
interface FastEthernet0/1
description R2 –> R1
ip address 10.20.100.1 255.255.255.252

duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 99
network 10.20.100.0 0.0.0.3
network 10.30.100.0 0.0.0.3
network 80.0.0.0
no auto-summary
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
password rahman
login
transport preferred none
!
end

=================================================================================================

R3#sh run
Building configuration…

Current configuration : 917 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$KN/W$YmAcjxkkXQRz51bT/7jDw0
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback30
ip address 90.0.0.1 255.255.255.255
!
interface FastEthernet0/0
description R3 –> R1
ip address 10.10.100.2 255.255.255.252

duplex auto
speed auto
!
interface FastEthernet0/1
description R3 –> R2
ip address 10.30.100.1 255.255.255.252

duplex auto
speed auto
!
router eigrp 99
network 10.10.100.0 0.0.0.3
network 10.30.100.0 0.0.0.3
network 90.0.0.0
no auto-summary
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
password rahman
login
transport preferred none
!
end

________________________________________________________________________________________________________

Verifikasi Routing dan Equal-cost Load balancing EIGRP _____________________________________________________________________________________________ show ip route

R1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

70.0.0.0/32 is subnetted, 1 subnets
C 70.0.0.1 is directly connected, Loopback10
80.0.0.0/32 is subnetted, 1 subnets
D 80.0.0.1 [90/156160] via 10.20.100.1, 00:00:40, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.8.8.0/24 is directly connected, FastEthernet1/0
C 10.10.100.0/30 is directly connected, FastEthernet0/0
D 10.30.100.0/30 [90/30720] via 10.10.100.2, 00:00:45, FastEthernet0/0
[90/30720] via 10.20.100.1, 00:00:45, FastEthernet0/1
C 10.20.100.0/30 is directly connected, FastEthernet0/1
90.0.0.0/32 is subnetted, 1 subnets
D 90.0.0.1 [90/156160] via 10.10.100.2, 00:00:41, FastEthernet0/0

R2#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

70.0.0.0/32 is subnetted, 1 subnets
D 70.0.0.1 [90/156160] via 10.20.100.2, 00:00:04, FastEthernet0/1
80.0.0.0/32 is subnetted, 1 subnets
C 80.0.0.1 is directly connected, Loopback20
10.0.0.0/30 is subnetted, 3 subnets
D 10.10.100.0/30 [90/30720] via 10.20.100.2, 00:00:04, FastEthernet0/1
[90/30720] via 10.30.100.1, 00:00:04, FastEthernet0/0
C 10.30.100.0/30 is directly connected, FastEthernet0/0
C 10.20.100.0/30 is directly connected, FastEthernet0/1
90.0.0.0/32 is subnetted, 1 subnets
D 90.0.0.1 [90/156160] via 10.30.100.1, 00:00:04, FastEthernet0/0

R3#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

70.0.0.0/32 is subnetted, 1 subnets
D 70.0.0.1 [90/156160] via 10.10.100.1, 00:02:42, FastEthernet0/0
80.0.0.0/32 is subnetted, 1 subnets
D 80.0.0.1 [90/156160] via 10.30.100.2, 00:02:42, FastEthernet0/1
10.0.0.0/30 is subnetted, 3 subnets
C 10.10.100.0/30 is directly connected, FastEthernet0/0
C 10.30.100.0/30 is directly connected, FastEthernet0/1
D 10.20.100.0/30 [90/30720] via 10.10.100.1, 00:02:42, FastEthernet0/0
[90/30720] via 10.30.100.2, 00:02:42, FastEthernet0/1
90.0.0.0/32 is subnetted, 1 subnets
C 90.0.0.1 is directly connected, Loopback30

Perhatikan..! R1 memiliki 2 buah jalur route untuk menuju ke network yang berada antara R2 dan R3 yaitu 10.30.100.0/30. Hal ini juga berlaku untuk R2 dan R3. Nilai metrik/cost antara kedua jalur ini sama percis (pake C). Sebagai contoh kita jalankan command “show ip eigrp topology network” pada Router1.

R1#sh ip eigrp topology 10.30.100.0/30
IP-EIGRP (AS 99): Topology entry for 10.30.100.0/30
State is Passive, Query origin flag is 1, 2 Successor(s), FD is 30720
Routing Descriptor Blocks:
10.20.100.1 (FastEthernet0/1), from 10.20.100.1, Send flag is 0×0 >> via R2
Composite metric is (30720/28160), Route is Internal
Vector metric:
Minimum bandwidth is 100000 Kbit
Total delay is 200 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
10.10.100.2 (FastEthernet0/0), from 10.10.100.2, Send flag is 0×0 >> via R3
Composite metric is (30720/28160), Route is Internal
Vector metric:
Minimum bandwidth is 100000 Kbit
Total delay is 200 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500

Hop count is 1

Now, we will check is this load balancing really works ? We’ll ping to network 10.20.100.0/24 from R3.

R1#no ip cef

R1#debug ip packet

R1#ping 10.20.100.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.20.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/18/40 ms

From debug packet, we can see that to reach to net 10.20.100.0/30, R3 have two link that used balance (via R1 dan R2).

___________________________________________________________________________________________ Verifikasi Routing dan Unequal-cost EIGRP ___________________________________________________________________________________________

Untuk membuat metrik antara R1 ke kedua link tidak sama besar , maka kita akan menurunkan bandwidth/speed satu interface untuk mencapai network tersebut. Kita bisa juga memperbesar delay di salah satu interfacenya.

Saya akan menurunkan BW interface f0/0 dari R2.

R2#sh run int fa0/0
Building configuration…
Current configuration : 136 bytes
!
interface FastEthernet0/0
description R2 –> R3
bandwidth 128
ip address 10.30.100.2 255.255.255.252
duplex auto
speed auto
end

Dampaknya terhadap routing table di R1 :

R1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

70.0.0.0/32 is subnetted, 1 subnets
C 70.0.0.1 is directly connected, Loopback10
80.0.0.0/32 is subnetted, 1 subnets
D 80.0.0.1 [90/156160] via 10.20.100.1, 00:00:50, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.8.8.0/24 is directly connected, FastEthernet1/0
C 10.10.100.0/30 is directly connected, FastEthernet0/0
D 10.30.100.0/30 [90/30720] via 10.10.100.2, 00:00:51, FastEthernet0/0
C 10.20.100.0/30 is directly connected, FastEthernet0/1
90.0.0.0/32 is subnetted, 1 subnets
D 90.0.0.1 [90/156160] via 10.10.100.2, 00:00:51, FastEthernet0/0

R1#sh ip eigrp topology 10.30.100.0/30
IP-EIGRP (AS 99): Topology entry for 10.30.100.0/30
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 30720
Routing Descriptor Blocks:
10.10.100.2 (FastEthernet0/0), from 10.10.100.2, Send flag is 0×0
Composite metric is (30720/28160), Route is Internal > Trafik akan cenderung melalui link ini
Vector metric:
Minimum bandwidth is 100000 Kbit
Total delay is 200 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
10.20.100.1 (FastEthernet0/1), from 10.20.100.1, Send flag is 0×0
Composite metric is (20005120/20002560), Route is Internal
Vector metric:
Minimum bandwidth is 128 Kbit
Total delay is 200 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1

Saat ini, R1 ke network 10.30.100.0/30 hanya memiliki 1 Successor dan yang satunya adalah backup jika jalur pertama failure.

Berbeda dengan Equal-cost, jika kita melakukan ping ke network 10.30.100.0/30 dari R1, maka kebanyakan packet akan melewati R3(10.10.100.2) karena jalur ini lebih baik. Konsepnya tetap load balancing, hanya saja lebih diutamakan melalui R3 daripada R2(10.20.100.1).

~ Sudah Selesai… ~

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s