Configure Redistribution EIGRP Routing Between Different Autonomous System

Posted On 19 August 2009

Filed under EIGRP

Comments Dropped leave a response

Yupzz, siang ini kita coba melakukan konfigurasi redistibution EIGRP antara 2 Autonomous System. Seperti biasa kita pakai 3 Router untuk melakukan simulasinya.

Ini adalah diagram network yang akan kita buat…

EIGRP-2AS

Keterangan :

R1 : 40.0.0.1/24 (Loopback0), 10.8.8.254/24 (fa0/0) untuk remote dari jaringan dan 192.168.100.1/30 (fa0/1) untuk koneksi ke R2

R2 : 50.0.0.1/24 (Loopback0), 192.168.100.2/30 (fa0/0) Link to R1 dan 192.168.200.1/30 (fa0/1) Link to R3.

R3 : 60.0.0.1/24 (Loopback0) dan 192.168.200.2/30 (fa0/0) Link To R2.

Untuk Konfigurasinya So simple Like This … ______________________________________________________________________________________________________________

Show running-configuration _______________________________________________________________________________________________________________________________
R1#sh run
Building configuration…

Current configuration : 1006 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$wSiF$JbWv2GJzSC9Yhid3f/vuG0
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback0
ip address 40.0.0.1 255.255.255.0
!
interface FastEthernet0/0
description Link To Remote
ip address 10.8.8.254 255.255.255.0
speed 10
half-duplex
!
interface FastEthernet0/1
description Link To R2
ip address 192.168.100.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 145
network 40.0.0.0
network 192.168.100.0 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
no eigrp log-neighbor-warnings
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
password rahman
login
!
end

======================================================================================================================

Setting route-map disini digunakan untuk mencegah terjadinya loop routing EIGRP. Perhatikan bahwa router EIGRP 145 men-deny tag 145, tapi mem-permit tag 154. Begitu pula dengan EIGRP 154 yang deny tag 154, tapi permit tag 145.

R2#sh run
Building configuration…

Current configuration : 1197 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$7uG3$brabXzpiw85lkbSvBoIZH0
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback0
ip address 50.0.0.1 255.255.255.0
!
interface FastEthernet0/0
description Link To R1
ip address 192.168.100.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
description Link To R3
ip address 192.168.200.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 145
redistribute eigrp 154 route-map eigrp145
network 192.168.100.0 0.0.0.3
no auto-summary
!
router eigrp 154
redistribute eigrp 145 route-map eigrp154
network 50.0.0.0
network 192.168.200.0 0.0.0.3
no auto-summary
!
ip http server
ip classless
!
route-map eigrp154 deny 10
match tag 154
!
route-map eigrp154 permit 20
set tag 145
!
route-map eigrp145 deny 10
match tag 145
!
route-map eigrp145 permit 20
set tag 154
!
line con 0
line aux 0
line vty 0 4
password rahman
login
!
end

=============================================================================================

R3#sh run
Building configuration…

Current configuration : 866 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$pIXU$qmZHqX9oSRQwR8LHORRvZ1
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback0
ip address 60.0.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.200.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 154
network 60.0.0.0
network 192.168.200.0 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
no eigrp log-neighbor-warnings
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
password rahman
login
!
end

___________________________________________________________________________________________________________________________________

Verifikasi Routing dan Koneksi ________________________________________________________________________________________________________________________________________________
R1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route
Gateway of last resort is not set
50.0.0.0/24 is subnetted, 1 subnets
D EX 50.0.0.0 [170/156160] via 192.168.100.2, 00:05:53, FastEthernet0/1
192.168.200.0/30 is subnetted, 1 subnets
D EX 192.168.200.0 [170/30720] via 192.168.100.2, 00:06:11, FastEthernet0/1
40.0.0.0/24 is subnetted, 1 subnets
C 40.0.0.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.8.8.0 is directly connected, FastEthernet0/0
192.168.100.0/30 is subnetted, 1 subnets
C 192.168.100.0 is directly connected, FastEthernet0/1
60.0.0.0/24 is subnetted, 1 subnets
D EX 60.0.0.0 [170/158720] via 192.168.100.2, 00:00:39, FastEthernet0/1

R1#sh ip protocols
Routing Protocol is “eigrp 145”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 145
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
40.0.0.0
192.168.100.0/30
Routing Information Sources:
Gateway Distance Last Update
192.168.100.2 90 00:00:43
Distance: internal 90 external 170

R1#sh ip eigrp 145 neighbors detail
IP-EIGRP neighbors for process 145
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.100.2 Fa0/1 13 00:06:27 892 5000 0 7
Version 12.3/1.2, Retrans: 1, Retries: 0

R1#sh ip eigrp 145 topology
IP-EIGRP Topology Table for AS(145)/ID(40.0.0.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 192.168.100.0/30, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 40.0.0.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 50.0.0.0/24, 1 successors, FD is 156160, tag is 154
via 192.168.100.2 (156160/128256), FastEthernet0/1
P 60.0.0.0/24, 1 successors, FD is 158720, tag is 154
via 192.168.100.2 (158720/156160), FastEthernet0/1
P 192.168.200.0/30, 1 successors, FD is 30720, tag is 154
via 192.168.100.2 (30720/28160), FastEthernet0/1

R1#ping 50.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/20 ms

R1#ping 60.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/13/28 ms

=============================================================================================

R2#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
C 50.0.0.0 is directly connected, Loopback0
192.168.200.0/30 is subnetted, 1 subnets
C 192.168.200.0 is directly connected, FastEthernet0/1
40.0.0.0/24 is subnetted, 1 subnets
D 40.0.0.0 [90/156160] via 192.168.100.1, 00:07:13, FastEthernet0/0
192.168.100.0/30 is subnetted, 1 subnets
C 192.168.100.0 is directly connected, FastEthernet0/0
60.0.0.0/24 is subnetted, 1 subnets
D 60.0.0.0 [90/156160] via 192.168.200.2, 00:01:38, FastEthernet0/1

R2#sh ip protocols
Routing Protocol is “eigrp 145”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 145, eigrp 154
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.100.0/30
Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:08:31
192.168.100.1 90 00:07:24
Distance: internal 90 external 170

Routing Protocol is “eigrp 154”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 145, eigrp 154
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
50.0.0.0
192.168.200.0/30
Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:07:31
192.168.200.2 90 00:01:49
Distance: internal 90 external 170

R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 145
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.100.1 Fa0/0 13 00:07:37 14 200 0 7
IP-EIGRP neighbors for process 154
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.200.2 Fa0/1 13 00:02:05 4 200 0 2

R2#sh ip eigrp 145 neighbors detail
IP-EIGRP neighbors for process 145
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.100.1 Fa0/0 10 00:07:44 14 200 0 7
Version 12.3/1.2, Retrans: 1, Retries: 0

R2#sh ip eigrp 154 neighbors detail
IP-EIGRP neighbors for process 154
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.200.2 Fa0/1 11 00:02:16 4 200 0 2
Version 12.3/1.2, Retrans: 2, Retries: 0

R2#sh ip eigrp topology
IP-EIGRP Topology Table for AS(145)/ID(50.0.0.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 192.168.100.0/30, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 40.0.0.0/24, 1 successors, FD is 156160
via 192.168.100.1 (156160/128256), FastEthernet0/0
P 50.0.0.0/24, 1 successors, FD is 128256, tag is 154
via Redistributed (128256/0)
P 60.0.0.0/24, 1 successors, FD is 156160, tag is 154
via Redistributed (156160/0)
P 192.168.200.0/30, 1 successors, FD is 28160, tag is 154
via Redistributed (28160/0)
IP-EIGRP Topology Table for AS(154)/ID(50.0.0.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 192.168.100.0/30, 1 successors, FD is 28160, tag is 145
via Redistributed (28160/0)
P 40.0.0.0/24, 1 successors, FD is 156160, tag is 145
via Redistributed (156160/0)
P 50.0.0.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 60.0.0.0/24, 1 successors, FD is 156160
via 192.168.200.2 (156160/128256), FastEthernet0/1
P 192.168.200.0/30, 1 successors, FD is 28160
via Connected, FastEthernet0/1

R2#ping 40.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms

R2#ping 60.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/52 ms

====================================================================================

R3# sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
D 50.0.0.0 [90/156160] via 192.168.200.1, 00:02:34, FastEthernet0/0
192.168.200.0/30 is subnetted, 1 subnets
C 192.168.200.0 is directly connected, FastEthernet0/0
40.0.0.0/24 is subnetted, 1 subnets
D EX 40.0.0.0 [170/158720] via 192.168.200.1, 00:02:34, FastEthernet0/0
192.168.100.0/30 is subnetted, 1 subnets
D EX 192.168.100.0 [170/30720] via 192.168.200.1, 00:02:34, FastEthernet0/0
60.0.0.0/24 is subnetted, 1 subnets
C 60.0.0.0 is directly connected, Loopback0

R3#sh ip protocols
Routing Protocol is “eigrp 154”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 154
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
60.0.0.0
192.168.200.0/30
Routing Information Sources:
Gateway Distance Last Update
192.168.200.1 90 00:02:42
Distance: internal 90 external 170

R3#sh ip eigrp neighbors
IP-EIGRP neighbors for process 154
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.200.1 Fa0/0 14 00:02:51 4 200 0 2
R3#sh ip eigrp 154 neighbors det
R3#sh ip eigrp 154 neighbors detail
IP-EIGRP neighbors for process 154
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.200.1 Fa0/0 11 00:02:58 4 200 0 2
Version 12.3/1.2, Retrans: 1, Retries: 0

R3#sh ip eigrp topology
IP-EIGRP Topology Table for AS(154)/ID(60.0.0.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 192.168.100.0/30, 1 successors, FD is 30720, tag is 145
via 192.168.200.1 (30720/28160), FastEthernet0/0
P 40.0.0.0/24, 1 successors, FD is 158720, tag is 145
via 192.168.200.1 (158720/156160), FastEthernet0/0
P 50.0.0.0/24, 1 successors, FD is 156160
via 192.168.200.1 (156160/128256), FastEthernet0/0
P 60.0.0.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 192.168.200.0/30, 1 successors, FD is 28160
via Connected, FastEthernet0/0
R3#ping 40.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/21/24 ms
R3#ping 50.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/15/32 ms

Dan… Berhasil, berhasil, berhasil… Hore..!!!

~ S E L E S A I ~

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s