Configure Redistribution EIGRP With RIP

Posted On 19 August 2009

Filed under EIGRP

Comments Dropped leave a response

Melanjutkan belajar EIGRP, kali ini gw mo coba untuk configure redistribution EIGRP dengan RIP.

Gimana konfig yang gw lakukan ? Cekidot….

EIGRP-RIPKeterangan :

Router Jakarta : 10.0.0.254/24 (Loopback0), 10.8.8.254/24 (f0/0) untuk remote dan 172.16.10.1/30 (f0/1)

Router Bandung : 20.0.0.254/24 (Loopback0), 172.16.10.2/30 (f0/0) dan 192.168.10.1/30 (f0/1)

Router Yogya : 30.0.0.254/24 (Loopback0) dan 192.168.10.2/30 (f0/0) ____________________________________________________________________________________________

Show Configuration __________________________________________________________________________________________________

JAKARTA#sh run
Building configuration…

Current configuration : 1189 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname JAKARTA
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$oI7p$hV1Qqi9Io5ft6GjXW7TS5/
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback0
ip address 10.0.0.254 255.255.255.0
!
interface FastEthernet0/0
ip address 10.8.8.254 255.255.255.0
speed 10
half-duplex
!
interface FastEthernet0/1
ip address 172.16.10.1 255.255.255.252
duplex auto
speed auto
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
router eigrp 90
network 10.0.0.0 0.0.0.255
network 172.16.10.0 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
no eigrp log-neighbor-warnings
!
ip http server
ip classless
!
banner motd ^CCJ-Town Router^C
!
line con 0
password rahman
login
line aux 0
line vty 0 4
password rahman
login
!
end

=============================================================

BANDUNG#sh run
Building configuration…

Current configuration : 1133 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BANDUNG
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$3WlE$pCsAsHuOSevZUYk3P.gaK0
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback0
ip address 20.0.0.254 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 90
redistribute rip metric 10000000 20000 255 1 1500
network 20.0.0.0 0.0.0.255
network 172.16.10.0 0.0.0.3
network 192.168.10.0 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
no eigrp log-neighbor-warnings
!
router rip
version 2
redistribute eigrp 90
network 30.0.0.0
network 192.168.10.0
default-metric 4
!
ip http server
ip classless
!
banner motd ^CCB-Town Router^C
!
line con 0
password rahman
login
line aux 0
line vty 0 4
password rahman
login
!
end

=================================================================

YOGYA#sh run
Building configuration…

Current configuration : 850 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname YOGYA
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$3Ktc$mDR5hW.fTGgCky8w3rNbp/
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback0
ip address 30.0.0.254 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 30.0.0.0
network 192.168.10.0
no auto-summary
!
ip http server
ip classless
!
banner motd ^CY-Town^C
!
line con 0
line aux 0
line vty 0 4
password rahman
login
transport preferred none
!
end

_______________________________________________________________________________________________________

Verifikasi Routing dan Koneksi __________________________________________________________________________________________________________

JAKARTA#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets
D 20.0.0.0 [90/156160] via 172.16.10.2, 00:06:42, FastEthernet0/1
192.168.10.0/30 is subnetted, 1 subnets
D 192.168.10.0 [90/30720] via 172.16.10.2, 00:06:42, FastEthernet0/1
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, FastEthernet0/1
10.0.0.0/24 is subnetted, 2 subnets
C 10.8.8.0 is directly connected, FastEthernet0/0
C 10.0.0.0 is directly connected, Loopback0
30.0.0.0/24 is subnetted, 1 subnets
D EX 30.0.0.0 [170/5148160] via 172.16.10.2, 00:04:33, FastEthernet0/1 >>> External EIGRP

JAKARTA#sh ip protocols
Routing Protocol is “eigrp 90”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 90
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0/24
172.16.10.0/30
Routing Information Sources:
Gateway Distance Last Update
172.16.10.2 90 00:04:37
Distance: internal 90 external 170

JAKARTA#sh ip eigrp neighbors
IP-EIGRP neighbors for process 90
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.10.2 Fa0/1 13 00:12:47 5 200 0 3

JAKARTA#sh ip route eigrp 90
20.0.0.0/24 is subnetted, 1 subnets
D 20.0.0.0 [90/156160] via 172.16.10.2, 00:07:02, FastEthernet0/1
192.168.10.0/30 is subnetted, 1 subnets
D 192.168.10.0 [90/30720] via 172.16.10.2, 00:07:02, FastEthernet0/1
30.0.0.0/24 is subnetted, 1 subnets
D EX 30.0.0.0 [170/5148160] via 172.16.10.2, 00:04:54, FastEthernet0/1

JAKARTA#ping 20.0.0.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/8/16 ms

JAKARTA#ping 30.0.0.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/17/32 ms

===========================================================================

BANDUNG#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets
C 20.0.0.0 is directly connected, Loopback0
192.168.10.0/30 is subnetted, 1 subnets
C 192.168.10.0 is directly connected, FastEthernet0/1
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
D 10.0.0.0 [90/156160] via 172.16.10.1, 00:07:23, FastEthernet0/0
30.0.0.0/24 is subnetted, 1 subnets
R 30.0.0.0 [120/1] via 192.168.10.2, 00:00:08, FastEthernet0/1

BANDUNG#sh ip protocols
Routing Protocol is “eigrp 90”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 90, rip
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
20.0.0.0/24
172.16.10.0/30
192.168.10.0/30
Routing Information Sources:
Gateway Distance Last Update
172.16.10.1 90 00:07:37
Distance: internal 90 external 170

Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 22 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default redistribution metric is 4
Redistributing: eigrp 90, rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
30.0.0.0
192.168.10.0
Routing Information Sources:
Gateway Distance Last Update
192.168.10.2 120 00:00:23
Distance: (default is 120)

BANDUNG#sh ip route eigrp 90
10.0.0.0/24 is subnetted, 1 subnets
D 10.0.0.0 [90/156160] via 172.16.10.1, 00:08:08, FastEthernet0/0

BANDUNG#sh ip eigrp neighbors
IP-EIGRP neighbors for process 90
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.10.1 Fa0/0 14 00:12:54 3 200 0 3

BANDUNG#sh ip route rip
30.0.0.0/24 is subnetted, 1 subnets
R 30.0.0.0 [120/1] via 192.168.10.2, 00:00:07, FastEthernet0/1

BANDUNG#sh ip rip database
10.0.0.0/8 auto-summary
10.0.0.0/24 redistributed
[4] via 172.16.10.1,
20.0.0.0/8 auto-summary
20.0.0.0/24 redistributed
[1] via 0.0.0.0,
30.0.0.0/8 auto-summary
30.0.0.0/24
[1] via 192.168.10.2, 00:00:24, FastEthernet0/1
172.16.0.0/16 auto-summary
172.16.10.0/30 redistributed
[1] via 0.0.0.0,
192.168.10.0/24 auto-summary
192.168.10.0/30 directly connected, FastEthernet0/1

BANDUNG#ping 10.0.0.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/8 ms
BANDUNG#ping 30.0.0.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/24 ms

======================================================================

YOGYA#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

R 20.0.0.0/8 [120/4] via 192.168.10.1, 00:00:08, FastEthernet0/0
192.168.10.0/30 is subnetted, 1 subnets
C 192.168.10.0 is directly connected, FastEthernet0/0
R 172.16.0.0/16 [120/4] via 192.168.10.1, 00:00:08, FastEthernet0/0
R 10.0.0.0/8 [120/4] via 192.168.10.1, 00:00:08, FastEthernet0/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.0.0.0 is directly connected, Loopback0

YOGYA#sh ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 17 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
30.0.0.0
192.168.10.0
Routing Information Sources:
Gateway Distance Last Update
192.168.10.1 120 00:00:17
Distance: (default is 120)

YOGYA#sh ip route rip
R 20.0.0.0/8 [120/4] via 192.168.10.1, 00:00:06, FastEthernet0/0
R 172.16.0.0/16 [120/4] via 192.168.10.1, 00:00:06, FastEthernet0/0
R 10.0.0.0/8 [120/4] via 192.168.10.1, 00:00:06, FastEthernet0/0

YOGYA#sh ip rip database
10.0.0.0/8 auto-summary
10.0.0.0/8
[4] via 192.168.10.1, 00:00:22, FastEthernet0/0
20.0.0.0/8 auto-summary
20.0.0.0/8
[4] via 192.168.10.1, 00:00:22, FastEthernet0/0
30.0.0.0/8 auto-summary
30.0.0.0/24 directly connected, Loopback0
172.16.0.0/16 auto-summary
172.16.0.0/16
[4] via 192.168.10.1, 00:00:22, FastEthernet0/0
192.168.10.0/24 auto-summary
192.168.10.0/30 directly connected, FastEthernet0/0

YOGYA#ping 10.0.0.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/25/32 ms
YOGYA#ping 20.0.0.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/24 ms

~ S E L E S A I ~

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s