Configure Redistribution EIGRP Routing With IS-IS Routing Protocol

Posted On 7 September 2009

Filed under EIGRP

Comments Dropped leave a response

Selamat pagi… duhai blogger..!!! (pake gaya evie tamala, hehehe😛
Sekarang kita akan melakukan proses redistribution routing antara EIGRP dan IS-IS. Berikut ini diagram network yang akan kita coba buat. 



Beginilah konfigurasi yang ada di ketiga router tersebut ________________________________________________________________________________________________________

1. Router  Athos mengaktifkan EIGRP AS 99 dan menggunakan Tacacs+ server untuk login. Instalasi Tacacs+ servernya ada di sini. Untuk IP 202.47.66.253/29 hanya saya gunakan untuk melakukan remote ke router ini saja.

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Athos
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication enable default group tacacs+
aaa session-id common
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback10
 ip address 111.111.111.1 255.255.255.255
!
interface FastEthernet0/0
 description “Link for Remote Access”
 ip address 202.47.66.253 255.255.255.248
 duplex auto
 speed auto
!
interface Serial0/0
 description “Link To Porthos”
 ip address 7.7.7.1 255.255.255.252
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router eigrp 99
 network 7.7.7.0 0.0.0.3
 network 111.111.111.1 0.0.0.0
 no auto-summary
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 202.47.66.249
!
tacacs-server host 202.47.74.253 key chayank123
tacacs-server directed-request
!
line con 0
line aux 0
line vty 0 4
 password rahman
 transport preferred none
!
end



2. Router Porthos akan menjadi router yang melakukan redistribution antara 2 buah routing beda protokol ini. Untuk melakukan distribution dari IS-IS ke EIGRP formatnya :redistribute eirgp ASnumber level-ISIS metric
Sedangkan untuk me-distribute EIGRP ke ISIS, formatnya : 
redistribute isis level-ISIS metric {bandwidth} {delay} {load} {MTU}

{bandwith} in kbps and {delay} in per 10 micro second.
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Porthos
!
boot-start-marker
boot-end-marker
!
enable password rahman
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback20
 ip address 222.222.222.2 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 description “Link To Athos”
 ip address 7.7.7.2 255.255.255.252
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 description “Link To Aramis”
 ip address 8.8.8.1 255.255.255.252
 ip router isis
!
router eigrp 99
 redistribute isis level-1 metric 1024 10 255 1 1500
 network 7.7.7.0 0.0.0.3
 network 8.8.8.0 0.0.0.3
 network 222.222.222.2 0.0.0.0
 no auto-summary
!
router isis
 net 48.0001.0000.0000.0002.00
 redistribute eigrp 99 metric 25 level-1
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
 password rahman
 login
!
end


3. Router Aramis mengaktifkan protokol IS-IS.

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Aramis
!
boot-start-marker
boot-end-marker
!
enable password rahman
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
!
no voice hpi capture buffer
no voice hpi capture destination
!
interface Loopback30
 ip address 33.33.33.3 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 description “Link To Porthos”
 ip address 8.8.8.2 255.255.255.252
 ip router isis
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router isis
 net 48.0001.0000.0000.0003.00
!
ip http server
ip classless
!
line con 0
line aux 0
line vty 0 4
 password rahman
 login
!
end

______________________________________________________________________________________________________________ 
Verifikasi Routing and connection ________________________________________________________________________________________________________________
Athos#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route


Gateway of last resort is 202.47.66.249 to network 0.0.0.0


     202.47.66.0/29 is subnetted, 1 subnets
C       202.47.66.248 is directly connected, FastEthernet0/0
     222.222.222.0/32 is subnetted, 1 subnets
D       222.222.222.2 [90/2297856] via 7.7.7.2, 00:02:18, Serial0/0
     33.0.0.0/32 is subnetted, 1 subnets
D EX    33.33.33.3 [170/3014400] via 7.7.7.2, 00:02:18, Serial0/0
     7.0.0.0/30 is subnetted, 1 subnets
C       7.7.7.0 is directly connected, Serial0/0
     8.0.0.0/30 is subnetted, 1 subnets
D       8.8.8.0 [90/2681856] via 7.7.7.2, 00:02:18, Serial0/0
     111.0.0.0/32 is subnetted, 1 subnets
C       111.111.111.1 is directly connected, Loopback10
S*   0.0.0.0/0 [1/0] via 202.47.66.249

Athos#sh ip eigrp topology  
IP-EIGRP Topology Table for AS(99)/ID(111.111.111.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
       r – reply Status, s – sia Status

P 7.7.7.0/30, 1 successors, FD is 2169856
        via Connected, Serial0/0
P 8.8.8.0/30, 1 successors, FD is 2681856
        via 7.7.7.2 (2681856/2169856), Serial0/0
P 33.33.33.3/32, 1 successors, FD is 3014400
        via 7.7.7.2 (3014400/2502400), Serial0/0
P 111.111.111.1/32, 1 successors, FD is 128256
        via Connected, Loopback10
P 222.222.222.2/32, 1 successors, FD is 2297856
        via 7.7.7.2 (2297856/128256), Serial0/0



Athos#ping 33.33.33.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/41/72 ms
==================================================================================================

Porthos#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     222.222.222.0/32 is subnetted, 1 subnets
C       222.222.222.2 is directly connected, Loopback20
     33.0.0.0/32 is subnetted, 1 subnets
i L1    33.33.33.3 [115/20] via 8.8.8.2, Serial0/1
     7.0.0.0/30 is subnetted, 1 subnets
C       7.7.7.0 is directly connected, Serial0/0
     8.0.0.0/30 is subnetted, 1 subnets
C       8.8.8.0 is directly connected, Serial0/1
     111.0.0.0/32 is subnetted, 1 subnets
      111.111.111.1 [90/2297856] via 7.7.7.1, 00:00:54, Serial0/0



Porthos#sh ip eigrp topology
IP-EIGRP Topology Table for AS(99)/ID(222.222.222.2)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
       r – reply Status, s – sia Status

P 7.7.7.0/30, 1 successors, FD is 2169856
        via Connected, Serial0/0
P 8.8.8.0/30, 1 successors, FD is 2169856
        via Connected, Serial0/1
P 33.33.33.3/32, 1 successors, FD is 2502400
        via Redistributed (2502400/0)
P 111.111.111.1/32, 1 successors, FD is 2297856
        via 7.7.7.1 (2297856/128256), Serial0/0
P 222.222.222.2/32, 1 successors, FD is 128256
        via Connected, Loopback20

Porthos#sh isis hostname
Level  System ID      Dynamic Hostname  (notag)
     * 0000.0000.0002 Porthos
 1     0000.0000.0003 Aramis

Porthos#sh isis topology

IS-IS paths to level-1 routers
System Id            Metric     Next-Hop             Interface   SNPA
Porthos              —
Aramis               10         Aramis               Se0/1       *HDLC*        

IS-IS paths to level-2 routers
System Id            Metric     Next-Hop             Interface   SNPA
Porthos              —
Aramis               10         Aramis               Se0/1       *HDLC*  
 
===================================================================================================
Aramis#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     222.222.222.0/32 is subnetted, 1 subnets
i L1    222.222.222.2 [115/20] via 8.8.8.1, Serial0/0
     33.0.0.0/32 is subnetted, 1 subnets
C       33.33.33.3 is directly connected, Loopback30
     7.0.0.0/30 is subnetted, 1 subnets
i L1    7.7.7.0 [115/60] via 8.8.8.1, Serial0/0
     8.0.0.0/30 is subnetted, 1 subnets
C       8.8.8.0 is directly connected, Serial0/0
     111.0.0.0/32 is subnetted, 1 subnets
i L1    111.111.111.1 [115/60] via 8.8.8.1, Serial0/0

Aramis#sh isis hostname 
Level  System ID      Dynamic Hostname  (notag)
 1     0000.0000.0002 Porthos
     * 0000.0000.0003 Aramis
Aramis#sh isis top
Aramis#sh isis topology

IS-IS paths to level-1 routers
System Id            Metric     Next-Hop             Interface   SNPA
Porthos              10         Porthos              Se0/0       *HDLC*        
Aramis               —

IS-IS paths to level-2 routers
System Id            Metric     Next-Hop             Interface   SNPA
Porthos              10         Porthos              Se0/0       *HDLC*        
Aramis               —



Athos#ping 111.111.111.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 111.111.111.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/41/72 ms


Hasil verifikasi routing dan koneksi sudah sesuai dan dapat berjalan dengan baik.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s