Configure Simple OSPF Routing Protocol on Cisco (Point To Point Topology)

Posted On 11 September 2009

Filed under OSPF

Comments Dropped leave a response

Assalamu ‘alaikum….

Setelah kemarin hanya melakukan posting ‘informasi’ yang diperoleh dari internet. Sekarang saya akanback on the track. Yup, saatnya melakukan konfigurasi routing OSPF di router Cisco! Ya..eee😀. Disini, kita akan menggunakan 2 buah router aje.

Here is the network diagram…

 

Okeyh, let’s see how both router has configured, pretty simple.
___________________________________________________________________________________________________ 

Setup Router Configuration ___________________________________________________________________________________________________

Router Dableg

interface Loopback0
 description “AREA 1”
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 description “Link For Remote”
 ip address 202.47.66.253 255.255.255.248
 duplex auto
 speed auto
!
interface Serial0/0
 description “Link To Gebleg”
 ip address 100.100.100.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 1
 network 100.100.100.0 0.0.0.255 area 0

Router Gebleg

interface Loopback0
 description “Area 2”
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 description “Link To Dableg”
 ip address 100.100.100.2 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router ospf 20
 log-adjacency-changes
 network 2.2.2.0 0.0.0.255 area 2
 network 100.100.100.0 0.0.0.255 area 0

_________________________________________________________________________________________________

Verify ip route, ip ospf and connection status _________________________________________________________________________________________________

Dableg#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is 202.47.66.249 to network 0.0.0.0

     202.47.66.0/29 is subnetted, 1 subnets
C       202.47.66.248 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/65] via 100.100.100.2, 00:00:06, Serial0/0
     100.0.0.0/24 is subnetted, 1 subnets
C       100.100.100.0 is directly connected, Serial0/0
S*   0.0.0.0/0 [1/0] via 202.47.66.249

Dableg#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  –        00:00:31    100.100.100.2   Serial0/0
    
Dableg#sh ip ospf interface lo0
Loopback0 is up, line protocol is up
  Internet Address 1.1.1.1/24, Area 1
  Process ID 10, Router ID 1.1.1.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

Dableg#sh ip ospf interface s0/0
Serial0/0 is up, line protocol is up
  Internet Address 100.100.100.1/24, Area 0
  Process ID 10, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Index 1/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)

Dableg#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms ___________________________________________________________________________________________________________________________________

Gebleg#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/65] via 100.100.100.1, 00:01:15, Serial0/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     100.0.0.0/24 is subnetted, 1 subnets
C       100.100.100.0 is directly connected, Serial0/0
Gebleg#sh ip osp
Gebleg#sh ip ospf nei
Gebleg#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  –        00:00:30    100.100.100.1   Serial0/0

Gebleg#sh ip ospf interface lo0
Loopback0 is up, line protocol is up
  Internet Address 2.2.2.2/24, Area 2
  Process ID 20, Router ID 2.2.2.2, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

Gebleg#sh ip ospf interface s0/0 
Serial0/0 is up, line protocol is up
  Internet Address 100.100.100.2/24, Area 0
  Process ID 20, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Index 1/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)

Gebleg#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s